Keen IO and the “Heartbleed” OpenSSL Vulnerability

Share on facebook
Share on twitter
Share on pinterest

Hello all,

As many of you are aware a security vulnerability in OpenSSL was announced yesterday. Like most of the other sites on the Internet, Keen IO was vulnerable to this. We patched our systems around 9PM PST last night night and completed a deployment of new keys for our SSL certificates at 2:30PM PST today.

While we have no evidence that any attack was performed or that any material was exposed by this exploit, we believe it to be in the best interest of our users to do the following:

  • Change your password.
  • Generate new API keys. You can do this from your project’s page when logged in by clicking on “Show API Keys”. You’ll need to update your SDK usage or other Keen IO integrations.

If you have any questions feel free to drop us a line.

Share this post with your friends

Share on facebook
Share on google
Share on twitter
Share on linkedin

Subscribe to our Newsletter

Leave a Reply

Your email address will not be published. Required fields are marked *